Jump to content
ripas

Garmin 910 - Tips and Tricks Thread

Recommended Posts

Used the 910xt for it's third race last Sunday (Olympic Dist).

 

Overall swim time was correct but in Garmin Connect the map shows my start point (15m31s) about 910m into swim and distance was only 950m in total which includes 360m run to T1l. It really should have been closer to 1850m including run to transition. First real trouble I've noticed. Maybe it can't handle such a long run at end of swim?

 

Also the run pace seems to jump around a lot more than the 310.

Edited by PowerPete

Share this post


Link to post
Share on other sites

Used the 910xt for it's third race last Sunday (Olympic Dist).

 

Overall swim time was correct but in Garmin Connect the map shows my start point (15m31s) about 910m into swim and distance was only 950m in total which includes 360m run to T1l. It really should have been closer to 1850m including run to transition. First real trouble I've noticed. Maybe it can't handle such a long run at end of swim?

 

Also the run pace seems to jump around a lot more than the 310.

 

I noticed the same thing with my last race also. Enduro format, we did swim bike run swim bike run. Both swims started a little bit into the swim. I pressed the lap button I got out so I doubt that its got anything to do with the run section.

 

both swims to compare

http://connect.garmin.com/activity/147172276 We started in the water about 15 m from the edge. 390m recorded, no stroke graph.

http://connect.garmin.com/activity/147172291 I started it just before diving (actually hobbling over the stones) into the water. 410m recorded, No stroke graph

 

The official distance was meant to be 375M each.

 

I used to swim with the 310xt in the swim cap and it recorded really well as seen here. Has anyone tried it with the 910xt and does it recognise your breathing as a stroke? I know I know it might be asking a bit to much but just a thought as Im a uni-lateral swimmer it would still be the right number of strokes and rate.

Share this post


Link to post
Share on other sites

From DC Rainmaker - re: pace and units turning off. Also delays in the TSS/NP/IF updates:

 

 

There have been some confirmed issues with some folks and the FR910XT where the instant pace fluctuates a bit too much. In short, the smoothing isn’t applying correctly – so the pace jumps around a lot for some people (i.e. it shows 7:30, 7:35, 10:00, 6:30, 8:00, etc…). I don’t see it on my unit, but from the general trending it appears to be less impactful the faster you go (logical, given simple spreads of paces). Additionally, a complete satellite reset and giving it 20 minutes on the first turn on to reacquire satellites seems to fix it for others (no need on subsequent turn-ons).

Nonetheless, Garmin support has confirmed this to be an issue, and in talking with them they expect an update no later than early March – which will also include the FR910XT TSS/NP/IF updates that were promised for the unit. I should be getting some more detail on exactly when this update will occur sometime Friday. This update will also address a few of the other bugs that folks have run into, notably some around the unit shutting off mid-activity.

Additionally, the Edge 500 update for TSS/NP/IF is now in March – a slip of another month from the most recent promise of early February. Which of course, is a slip from every other date noted since August. Honestly, I put this in the category of ‘We’ll see it when it’s posted on Garmin.com’. Wish I had a better answer here.

Share this post


Link to post
Share on other sites

I noticed the same thing with my last race also. Enduro format, we did swim bike run swim bike run. Both swims started a little bit into the swim. I pressed the lap button I got out so I doubt that its got anything to do with the run section.

 

both swims to compare

http://connect.garmi...ivity/147172276 We started in the water about 15 m from the edge. 390m recorded, no stroke graph.

http://connect.garmi...ivity/147172291 I started it just before diving (actually hobbling over the stones) into the water. 410m recorded, No stroke graph

 

The official distance was meant to be 375M each.

 

I used to swim with the 310xt in the swim cap and it recorded really well as seen here. Has anyone tried it with the 910xt and does it recognise your breathing as a stroke? I know I know it might be asking a bit to much but just a thought as Im a uni-lateral swimmer it would still be the right number of strokes and rate.

 

 

Perhaps all the swim metrics weren't recorded because (presumably) you had it in open water swim mode? I don't know...just guessing.

Share this post


Link to post
Share on other sites

Haven't done a proper open water swim yet, but playing around with my daughter the other day it kept loosing the satellite and vibrating to let me know when I had my hand under water too long. So I'd turn off vibrate alerts in a race, just in case it gets a bit touchy and looses satellite repeatedly, feels weird having something vibrating on your wrist when your trying to swim.

Share this post


Link to post
Share on other sites

 

Perhaps all the swim metrics weren't recorded because (presumably) you had it in open water swim mode? I don't know...just guessing.

 

 

Yes that could be it, but surely it can count the strokes per min.. not that it matters during the race.

Share this post


Link to post
Share on other sites

I have now encountered the turning off issue.

 

The first time it happened on a ride at exactly the 70.00km point. On a very bumpy road, Maybe Vibration????? thinking back I have had the watch beep at me a couple of times when ive wacked my hand when running or whatever, but the watch hadnt gone off. Am I imagining it?

 

The second time the watch turned off was on a smooth road at about 5 hours. then when i turned it back on it had the message

"Hold RESET to save your activity".

rather than doing what it said (i wanted to keep the file going) i pressed start and it started again. but then the same message popped up, so maybe there is a point in the memory where it makes sure it can record it all and reminds u to save it. My watch is at 87% memory used.

 

Id hate for it to do it during an Ironman where i love to see where ive done well and not so well.

Share this post


Link to post
Share on other sites

I had it turn off mid ride at least a dozen times. Since then I have done a hard reset and it hasnt occured since so perhaps it may be related to a memory issue.......

 

Garmin are aware just hope the fix is not too far away!

 

Rattie where do you find how much memory has been used?

Share this post


Link to post
Share on other sites

I had it turn off mid ride at least a dozen times. Since then I have done a hard reset and it hasnt occured since so perhaps it may be related to a memory issue.......

 

Garmin are aware just hope the fix is not too far away!

 

Rattie where do you find how much memory has been used?

 

 

Mode > History> Memory Details

Share this post


Link to post
Share on other sites

I don't know if anyone said anything about this, but just in case ... since the "speed" is wrong, I've changed it to use the "Lap Pace". It seems like LP is calculated by "distance of lap"/"time of lap", so it's pretty accurate and MUCH better than "speed".

 

Until they fix it, it's an option.

 

Cheers,

 

PS: I want the DATE to put in my "watch" mode :(

Edited by Oscar

Share this post


Link to post
Share on other sites

Rode past Avantiplus in cannington just to grab a valve cap today and there it was in the cabinet so I now have a 910 too. Was pretty stoked after hearing about shocking wait times or pre order. Now have to sell the 410 and convince the gf it's the watch I've always had :)

 

Interesting thread. Will print at work and have a read through.

Share this post


Link to post
Share on other sites

Ive got the quick release kit.

 

IMG_0460.jpg

 

IMG_0461.jpg

IMG_0448.jpg

 

it feels a fair bit snugger, less height to it and the weak point in the mount last time has been beefed up.

Share this post


Link to post
Share on other sites

FYI - I read that there will be a firmware update available before the end of february to fix the pace/speed issues we may experience

Share this post


Link to post
Share on other sites

with the present 20% discount from wiggle 310xt is only around 300 bucks (with HRM)

 

sorry this topic has not help 1 bit with my confidence and desire for 910xt. Seems like it is riddled with problems !

Share this post


Link to post
Share on other sites

sorry this topic has not help 1 bit with my confidence and desire for 910xt. Seems like it is riddled with problems !

 

 

I was going to say that is common with first adopters of anything. However I stuck with a second hand 310xt over the 910xt because the wim metrics where the only change in functionality other than form factor. So am not sure if it counts as a 'first release' of a product. Although most of the issues do seem to be swim related?

Share this post


Link to post
Share on other sites

Has anyone got the bike mount kit on yet? Where's the best place to buy from?

 

highlytunedathletes had them, currently out of stock but get on the waiting list.

 

brillaint service indeed

Share this post


Link to post
Share on other sites

garmin connect is the only place where you can look at you swim. Strava doesn't like the file type and traing center just palin doesn't want to know about it.

 

I 've used it for 3 swims now and with anything other the straight laps of freestyle it is crap at counting laps and distance.

 

Did 5 fast 100's today and for some it though I was doing butterfly.

 

maybe some more work needed on my part.

 

also go the dropout or 0kph reading 3 time on my last long ride, At least I'm not getting the turning off, yet. Lets hope it play ball in NZ

 

 

On the plus side it's a lot more comfortable to where and looks a lot better.

Share this post


Link to post
Share on other sites

activestride.com.au posted yesterday that they filled there pre orders and now have the 910 with HRM package in stock for sale. Still haven't filled pre orders on the watch alone.

Share this post


Link to post
Share on other sites

Rebel stores finally have stock for those sitting on Xmas vouchers from family (Don't forget to sign up to their Rebel Season Pass thingy first as you'll get $40 in e vouchers. Then claim your 5% NRMA discount in store and it is almost on-line competitive).

 

Just whacked mine on the charger and it says "charging 100%" and some random time which has changed a few times. Is it totally full or totally empty? Weird if it comes charged.

Share this post


Link to post
Share on other sites

Called rebel at Campbelltown, 3 of them had just arrived. They price matched $399 and then beat it by %10 so I only paid $360 and now have it in my hot little hands.

Share this post


Link to post
Share on other sites

To top it off i got home and opened the box to find it it has the heart rate strap in the box....bit of luck!

Edited by knoxxy

Share this post


Link to post
Share on other sites

Hey all - Looks like the firmware update for the 910XT has been release:

 

https://buy.garmin.com/shop/store/downloadsAgree.jsp?product=010-00741-20&ra=true

 

 

Release Notes:

 

Latest release date: February 23, 2012

 

Changes made from version 2.30 to 2.40:

 

  • Improved calculation of instantaneous pace.
  • Fixed occasional watch freeze issue during pool swim.
  • Fixed potential dropout of speed/cadence data when using speed/cadence sensor and particular power meters when GPS off.
  • Fixed occasional problem of multisport activities containing pool swim not uploading to Garmin Connect.
  • Made improvement to reduce elevation spikes at beginning of activities.

 

Share this post


Link to post
Share on other sites

Does anyone have the pdf of the full user booklet? My computer apparently doesn't like opening it.

 

 

pm your email address and i will send it to you.

Share this post


Link to post
Share on other sites

Has anyone had their screen lock?? Mine is currently displaying "Transferring data", the ANNT stick is not receiving any data and I can't activate any of the keys. Not even the off button. And I've tried the mode+up arrow unlock protocol.

 

Nothing,

 

frozen,

 

dead,

 

unhappy.

 

Edit to add: I didn't hold the off key long enough (it helps to word search the manual, doh)

Edited by tortoise

Share this post


Link to post
Share on other sites

I did my first open water swim last Sunday at WSTC race and I'm really impressed with the performance of the 910 (not with my performance, but I knew the 910 wouldn't help me :))

http://connect.garmin.com/activity/152602644

Really smooth ... very happy.

 

The same with the Update firmware process, I'll today how the new version goes :)

 

I must accept I was a big fan of Polar but I was missing A LOT :)

Share this post


Link to post
Share on other sites

I've had mine start to have the turn off thing during rides. Last weeks long ride had it turn off 7 times over 4 hours.

 

It's been mentioned that i may be caused by vibrations when attached to the aero bars. Wore it on my wrist for an hour ride this morning with no problems.

 

Was thinking I'd try and rig up something on the mount to help absorb the vibrations. Any ideas?

 

The update mentioned above doesn't mention anything about this issue. :(

Share this post


Link to post
Share on other sites

OK. Why won't this morning's session download? It's buzzing away, starts to download but keeps failing before it's finished. I have training centre off, but if I do turn it on it tells me that it has successfully retreived all data from the device. Rubbish, rubbish, rubbish. I'm tired and cranky and I'm not even doing ironman.

Share this post


Link to post
Share on other sites

I've had mine start to have the turn off thing during rides. Last weeks long ride had it turn off 7 times over 4 hours.

 

It's been mentioned that i may be caused by vibrations when attached to the aero bars. Wore it on my wrist for an hour ride this morning with no problems.

 

Was thinking I'd try and rig up something on the mount to help absorb the vibrations. Any ideas?

 

The update mentioned above doesn't mention anything about this issue. :(

 

 

 

Ive resorted to mounting mine on a big spring but damn its hard to read :P

Share this post


Link to post
Share on other sites

 

 

Ive resorted to mounting mine on a big spring but damn its hard to read :P

 

I had the same problem with my 301, I ended up wrapping some thin high density foam around the mount (mainly under the watch itself). That seemed to work well for all but the biggest pothole. I've had it happen once with the 910 (most times it's on my wrist), and it was a big pothole, otherwise the foam seems to do the trick.

Share this post


Link to post
Share on other sites
After the upgrade should it say version 2.20 still?

Nope. Mine says 2.40.

If you are upgrading via the website, you have to make sure you make several garmin websites 'safe' in internet explorer otherwise the ant+ agent doesnt receive the update to transfer to your 910. It says update is complete, but dont be fooled.

I took the following from coolrunnings. Could get a link to work, hope that is ok?

 

 

 

Can you check if you have added all three Garmin https sites to your list of Trusted Sites in the Security tab under Internet Options:

https://buy.garmin.com

https://my.garmin.com

https://connect.garmin.com

 

If you don't see the firmware ready to upload within the ANT agent, something most likely went wrong and it's not ready to be uploaded to the 610

 

On IE8 I also noticed the firmware update page doesn't correctly work while it contains mixed content (both http and https). As a result you can see a message "Do you want to view only the webpage content that was delivered securely?" To resolve this issue, in Internet Exlorer

1.Going to Tools->Internet Options->Security

2.Select the ‘Security’ tab

3.Click the ‘Custom Level’ button

4.In the ‘Miscellaneous’ section change “Display mixed content” to Enable

 

Share this post


Link to post
Share on other sites

 

It seems to be working much better now.

 

 

Yup. Much better. Took it for a run this morning and it worked properly this time.

 

 

After the upgrade should it say version 2.20 still?

 

 

Nope. Should say 2.40

Share this post


Link to post
Share on other sites

OK I have now joined the club - including a foot pod - and done my first excercise (a pool swim).

 

A few teething problems and finger trouble but overall still managed to get some good data - no of strokes and average speed lap per lap. Awesome - I can now benchmark my swimming and, hopefully, my improvement.

 

BTW, can someone tell me what is a reasonable number of strokes is per lap? I would tell you mine but I would probably get laughed off this forum...! :lol:

Edited by Pete

Share this post


Link to post
Share on other sites

OK I have now joined the club - including a foot pod - and done my first excercise (a pool swim).

 

A few teething problems and finger trouble but overall still managed to get some good data - no of strokes and average speed lap per lap. Awesome - I can now benchmark my swimming and, hopefully, my improvement.

 

BTW, can someone tell me what is a reasonable number of strokes is per lap? I would tell you mine but I would probably get laughed off this forum...! :lol:

 

 

I'm still wary on the swimming numbers - Today I did a couple of km and garmin connect had me doing a few scattered 50m laps in 12seconds-25 seconds at times. It throws everything out, I reckon each swim is off by about 100-250m..

 

Every other function works fine but so far the swimming accuracy is a little disappointing. Hoping it will get better with time (aka firmware updates)

Share this post


Link to post
Share on other sites

 

 

I'm still wary on the swimming numbers - Today I did a couple of km and garmin connect had me doing a few scattered 50m laps in 12seconds-25 seconds at times. It throws everything out, I reckon each swim is off by about 100-250m..

 

Every other function works fine but so far the swimming accuracy is a little disappointing. Hoping it will get better with time (aka firmware updates)

 

 

I rekon the software is to smart for it's own good, I've had the same thing happen and have noticed normally it won't log a la until you've turned and commenced the next ( so when you stop it reads 1 lap short until you hit lap or wait for a while. If you wait too long the last lap gets logged and then if you take off again without hitting lap it starts a new lap and you end up 1 lap extra, it's been doing this constantly. So as long as your using lap for any stops more than a few seconds it's fine, but try to record a session with intervals in one lap and you get issues

Share this post


Link to post
Share on other sites

BTW, can someone tell me what is a reasonable number of strokes is per lap?

 

3*1000

3x1000.jpg

 

4*500

4x500.jpg

 

7*300

7x300.jpg

Share this post


Link to post
Share on other sites

Nope. Mine says 2.40.

If you are upgrading via the website, you have to make sure you make several garmin websites 'safe' in internet explorer otherwise the ant+ agent doesnt receive the update to transfer to your 910. It says update is complete, but dont be fooled.

I took the following from coolrunnings. Could get a link to work, hope that is ok?

 

 

 

Can you check if you have added all three Garmin https sites to your list of Trusted Sites in the Security tab under Internet Options:

https://buy.garmin.com

https://my.garmin.com

https://connect.garmin.com

 

If you don't see the firmware ready to upload within the ANT agent, something most likely went wrong and it's not ready to be uploaded to the 610

 

On IE8 I also noticed the firmware update page doesn't correctly work while it contains mixed content (both http and https). As a result you can see a message "Do you want to view only the webpage content that was delivered securely?" To resolve this issue, in Internet Exlorer

1.Going to Tools->Internet Options->Security

2.Select the ‘Security’ tab

3.Click the ‘Custom Level’ button

4.In the ‘Miscellaneous’ section change “Display mixed content” to Enable

 

 

Thanks mate...now says version 2.40

Wonder if it shows the current run pace better?

About to find out!

We've had 12 inches of rain (296mm) since Sunday (5 days)....best part is ...so many choices on where to swim!

Share this post


Link to post
Share on other sites

3*1000

3x1000.jpg

 

4*500

4x500.jpg

 

7*300

7x300.jpg

 

 

Oscar, pleast tell me that was a 25m pool! You do just over half the strokes I do - I think I have found a serously problem with my swimming!

Share this post


Link to post
Share on other sites

Calibrated my footpod last night and ran with it this morning with my 910. I know footpods are not 910 specific but would recommend them to anyone - the instantaneous run pace is solid as and does not jump around at all, yet very responsive to your changes in pace. ...and I get run cadence which I am using to try and bring my run stride rate above 90 - this thing is a runners dream!

 

Big problem with the ANT+ stick, but. It's almost like I have to "re attach or reinstall' every time before it will see watch and download the file. Any thoughts?

 

Also, whenever I hit the stop/start button to turn on the backlight (most of my runs are in the morning before sunrise) the light comes on but it displays some kind of brightness slider that obscures the picture. Can I get rid of this slider?

Share this post


Link to post
Share on other sites

If it's like the 310 then hitting any other button once will bring the light on also without actually doing what the button is supposed to do. The power button on the 310 is to allow you to change the duration of the light.

Share this post


Link to post
Share on other sites

 

Oscar, pleast tell me that was a 25m pool! You do just over half the strokes I do - I think I have found a serously problem with my swimming!

 

Yes, it's a 25 meters. Are we two? I mean, two with problem swimming? :) I don't really care ... for me the swim is part of the T1 :)

 

Regarding to the light, if you just press once the ON button, it shows the intensity of the light.

Share this post


Link to post
Share on other sites

If you double tap the glass screen it turns the light on!

Pace is much better since the update, seems pretty stable except when you run under trees then it fluctuates a little.

Still think the premium heart rate strap is a peice of shit, constantly spikes unless I am soaking wet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...